Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
O
OpenWRT
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to JiHu GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Panda
OpenWRT
Commits
a53b084e
Commit
a53b084e
authored
12 years ago
by
John Crispin
Browse files
Options
Downloads
Patches
Plain Diff
add ccache wrapper
SVN-Revision: 32075
parent
84a88534
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
4
Hide whitespace changes
Inline
Side-by-side
Showing
4 changed files
rules.mk
+6
-2
6 additions, 2 deletions
rules.mk
tools/ccache/Makefile
+10
-0
10 additions, 0 deletions
tools/ccache/Makefile
tools/ccache/files/ccache_cc
+2
-0
2 additions, 0 deletions
tools/ccache/files/ccache_cc
tools/ccache/files/ccache_cxx
+2
-0
2 additions, 0 deletions
tools/ccache/files/ccache_cxx
with
20 additions
and
2 deletions
rules.mk
+
6
−
2
View file @
a53b084e
...
...
@@ -188,8 +188,12 @@ INSTALL_DATA:=install -m0644
INSTALL_CONF
:=
install -m0600
ifneq
($(CONFIG_CCACHE),)
TARGET_CC
:=
ccache
$(
TARGET_CC
)
TARGET_CXX
:=
ccache
$(
TARGET_CXX
)
TARGET_CC_NOCACHE
:=
$(
TARGET_CC
)
TARGET_CXX_NOCACHE
:=
$(
TARGET_CXX
)
export
TARGET_CC_NOCACHE
export
TARGET_CXX_NOCACHE
TARGET_CC
:=
ccache_cc
TARGET_CXX
:=
ccache_cxx
HOSTCC
:=
ccache
$(
HOSTCC
)
endif
...
...
This diff is collapsed.
Click to expand it.
tools/ccache/Makefile
+
10
−
0
View file @
a53b084e
...
...
@@ -17,6 +17,11 @@ PKG_CAT:=zcat
include
$(INCLUDE_DIR)/host-build.mk
define
Host/Install/ccache
$(INSTALL_DIR)
$(STAGING_DIR_HOST)/bin/
$(CP)
./files/*
$(STAGING_DIR_HOST)/bin/
endef
ifneq
($(strip $(shell which ccache >/dev/null && echo found)),found)
define
Host/Compile
$(MAKE)
CC
=
"
$(
HOSTCC_NOCACHE
)
"
-C
$(
HOST_BUILD_DIR
)
...
...
@@ -26,6 +31,10 @@ ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
-$(MAKE)
-C
$(HOST_BUILD_DIR)
uninstall
$(
call
Host/Clean/Default
)
endef
define
Host/Install
$(
call
Host/Install/Default
)
$(
call
Host/Install/ccache
)
endef
else
define
Host/Prepare
endef
...
...
@@ -34,6 +43,7 @@ else
define
Host/Compile
endef
define
Host/Install
$(
call
Host/Install/ccache
)
endef
define
Host/Clean
endef
...
...
This diff is collapsed.
Click to expand it.
tools/ccache/files/ccache_cc
0 → 100755
+
2
−
0
View file @
a53b084e
#!/bin/sh
exec
ccache
"
${
TARGET_CC_NOCACHE
}
"
"
$@
"
This diff is collapsed.
Click to expand it.
tools/ccache/files/ccache_cxx
0 → 100755
+
2
−
0
View file @
a53b084e
#!/bin/sh
exec
ccache
"
${
TARGET_CXX_NOCACHE
}
"
"
$@
"
This diff is collapsed.
Click to expand it.
Panda
@nju
mentioned in commit
5a1eb3bb
·
2 years ago
mentioned in commit
5a1eb3bb
mentioned in commit 5a1eb3bb2c27ede3046bb2977008c74a04681db9
Toggle commit list
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment