Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Guix Cuirass
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to JiHu GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Panda
Guix Cuirass
Commits
5efdcb44
Commit
5efdcb44
authored
8 years ago
by
Mathieu Lirzin
Browse files
Options
Downloads
Patches
Plain Diff
Add a '--database' command line argument.
parent
944f8b54
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
bin/cuirass.in
+5
-2
5 additions, 2 deletions
bin/cuirass.in
configure.ac
+6
-0
6 additions, 0 deletions
configure.ac
src/cuirass/config.scm.in
+4
-0
4 additions, 0 deletions
src/cuirass/config.scm.in
with
15 additions
and
2 deletions
bin/cuirass.in
+
5
−
2
View file @
5efdcb44
...
...
@@ -21,7 +21,8 @@ exec ${GUILE:-@GUILE@} --no-auto-compile -e main -s "$0" "$@"
;;; You should have received a copy of the GNU General Public License
;;; along with Cuirass. If not, see <http://www.gnu.org/licenses/>.
(
use-modules
(
cuirass
base
)
(
use-modules
(
cuirass
config
)
(
cuirass
base
)
(
cuirass
database
)
(
cuirass
job
)
(
cuirass
ui
)
...
...
@@ -34,6 +35,7 @@ exec ${GUILE:-@GUILE@} --no-auto-compile -e main -s "$0" "$@"
Run Guix job from a git repository cloned in CACHEDIR.
-f --use-file=FILE Use FILE which defines the job to evaluate
-D --database=DB Use DB to store build results.
-I, --interval=N Wait N seconds between each evaluation
-V, --version Display version
-h, --help Display this help message"
)
...
...
@@ -42,6 +44,7 @@ Run Guix job from a git repository cloned in CACHEDIR.
(
define
%options
`
((
file
(
single-char
#\f
)
(
value
#t
))
(
database
(
single-char
#\f
)
(
value
#t
))
(
interval
(
single-char
#\I
)
(
value
#t
))
(
version
(
single-char
#\V
)
(
value
#f
))
(
help
(
single-char
#\h
)
(
value
#f
))))
...
...
@@ -109,7 +112,7 @@ DIR if required."
(
exit
0
))
(
else
(
let*
((
specfile
(
option-ref
opts
'file
"tests/hello-subset.scm"
))
(
dbfile
"tmp.db"
)
(
dbfile
(
option-ref
opts
'database
%package-database
)
)
(
specs
(
primitive-load
specfile
))
(
args
(
option-ref
opts
'
()
#f
))
(
cachedir
(
if
(
null?
args
)
...
...
This diff is collapsed.
Click to expand it.
configure.ac
+
6
−
0
View file @
5efdcb44
...
...
@@ -8,6 +8,12 @@ AM_SILENT_RULES([yes]) # enables silent rules by default
AC_CANONICAL_HOST
# Prepare a version of $localstatedir that does not contain references to
# shell variables.
expanded_prefix="`eval echo $prefix | sed -e "s|NONE|/usr/local|g"`"
expanded_localstatedir="`eval echo $localstatedir | sed -e "s|NONE|$expanded_prefix|g"`"
AC_SUBST([expanded_localstatedir])
PKG_CHECK_MODULES([GUILE], [guile-2.0 >= 2.0.7])
AC_PATH_PROG([GUILE], [guile])
AC_PATH_PROG([GUILD], [guild])
...
...
This diff is collapsed.
Click to expand it.
src/cuirass/config.scm.in
+
4
−
0
View file @
5efdcb44
...
...
@@ -46,3 +46,7 @@
(define-public %package-version
;; Define to the version of this package.
"@PACKAGE_VERSION@")
(define-public %package-database
;; Define to the database file name of this package.
(string-append "@expanded_localstatedir@/" %package ".db"))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment