提交 7db06855 编辑于 作者: Zachary Garrett's avatar Zachary Garrett 提交者: tensorflow-copybara
浏览文件

Revert release dependencies to match TensorFlow 2.5.0's dependency on 1.34.

https://github.com/tensorflow/tensorflow/blob/v2.5.0/tensorflow/tools/pip_package/setup.py#L130

Fix the nightly package to depend on gRPC 1.37 which was updated recently.

PiperOrigin-RevId: 374208257
上级 c11235d9
......@@ -60,7 +60,7 @@ REQUIRED_PACKAGES = [
'attrs~=19.3.0',
'cachetools~=3.1.1',
'dm-tree~=0.1.1',
'grpcio~=1.37.0',
'grpcio~=1.34.0',
'jax~=0.2.8',
'jaxlib~=0.1.55',
'numpy~=1.19.2',
......@@ -96,7 +96,7 @@ if '--nightly' in sys.argv:
for index, required_package in enumerate(REQUIRED_PACKAGES):
package_name = get_package_name(required_package)
if package_name == 'grpcio':
REQUIRED_PACKAGES[index] = 'grpcio~=1.34.0'
REQUIRED_PACKAGES[index] = 'grpcio~=1.37.0'
elif package_name == 'tensorflow':
REQUIRED_PACKAGES[index] = 'tf-nightly'
else:
......
Supports Markdown
0% .
You are about to add 0 people to the discussion. Proceed with caution.
先完成此消息的编辑!
想要评论请 注册