Unverified Commit dfd50a9d authored by Mike McQuaid's avatar Mike McQuaid Committed by GitHub
Browse files

Merge pull request #12491 from Homebrew/dependabot/bundler/Library/Homebrew/parser-3.0.3.1

build(deps): bump parser from 3.0.3.0 to 3.0.3.1 in /Library/Homebrew
parents 13314ca3 df0258b9
......@@ -73,7 +73,7 @@ GEM
parser
rainbow (~> 3.0)
sorbet-runtime (>= 0.5)
parser (3.0.3.0)
parser (3.0.3.1)
ast (~> 2.4.1)
patchelf (1.3.0)
elftools (>= 1.1.3)
......
......@@ -376,6 +376,7 @@ class Parser::Builders::Default
def unary_op_map(op_t, arg_e = T.unsafe(nil)); end
def unquoted_map(token); end
def validate_definee(definee); end
def validate_no_forward_arg_after_restarg(args); end
def value(token); end
def var_send_map(variable_e); end
def variable_map(name_t); end
......@@ -411,6 +412,7 @@ class Parser::Context
def empty?; end
def in_block?; end
def in_class?; end
def in_def_open_args?; end
def in_dynamic_block?; end
def in_lambda?; end
def indirectly_in_def?; end
......@@ -1599,8 +1601,10 @@ class Parser::StaticEnvironment
def initialize; end
def declare(name); end
def declare_anonymous_blockarg; end
def declare_forward_args; end
def declared?(name); end
def declared_anonymous_blockarg?; end
def declared_forward_args?; end
def empty?; end
def extend_dynamic; end
......@@ -1609,6 +1613,7 @@ class Parser::StaticEnvironment
def unextend; end
end
Parser::StaticEnvironment::ANONYMOUS_BLOCKARG = T.let(T.unsafe(nil), Symbol)
Parser::StaticEnvironment::FORWARD_ARGS = T.let(T.unsafe(nil), Symbol)
class Parser::SyntaxError < ::StandardError
......
......@@ -56,7 +56,7 @@ $:.unshift "#{path}/../#{ruby_engine}/#{ruby_version}/gems/method_source-1.0.0/l
$:.unshift "#{path}/../#{ruby_engine}/#{ruby_version}/gems/mustache-1.1.1/lib"
$:.unshift "#{path}/../#{ruby_engine}/#{ruby_version}/gems/parallel-1.21.0/lib"
$:.unshift "#{path}/../#{ruby_engine}/#{ruby_version}/gems/parallel_tests-3.7.3/lib"
$:.unshift "#{path}/../#{ruby_engine}/#{ruby_version}/gems/parser-3.0.3.0/lib"
$:.unshift "#{path}/../#{ruby_engine}/#{ruby_version}/gems/parser-3.0.3.1/lib"
$:.unshift "#{path}/../#{ruby_engine}/#{ruby_version}/gems/rainbow-3.0.0/lib"
$:.unshift "#{path}/../#{ruby_engine}/#{ruby_version}/gems/sorbet-runtime-0.5.9368/lib"
$:.unshift "#{path}/../#{ruby_engine}/#{ruby_version}/gems/parlour-6.0.1/lib"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment